Eclipse 실행시 exit code=1 에러 Ubuntu / Linux



eclipse버전과 맞는 java 버전을 찾을수 없을때 발생한다.

즉 java가 설치되어 있지 않거나 여러버전의 java가 설치되어 있지만 기본 java버전과 맞지 않기 때문일 수 있다.

아래와 같이 실행하면 기본으로 사용할 java를 설정할 수 있다.

    sudo update-alternatives --config java

기본으로 실행될 java버전을 바꾸는 방법도 있지만 가능하면 ini파일을 수정하여 eclipse실행시에만 특정 java버전을 실행하도록 해주자.

eclipse.ini파일을 열고 -vmargs 윗줄에 -vm을 추가해주자.

그리고 아랫쪽에 java의 경로를 입력해주면 된다.

-startup
plugins/org.eclipse.equinox.launcher_1.3.100.v20150511-1540.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.300.v20150602-1417
-product
org.eclipse.epp.package.cpp.product
--launcher.defaultAction
openFile
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
--launcher.appendVmargs

-vm
/usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java

-vmargs
-Dosgi.requiredJavaVersion=1.7
-XX:MaxPermSize=256m
-Xms256m
-Xmx1024m

덧글

댓글 입력 영역